Page 1 of 1

First Class E from Indonesia

PostPosted: Sat Nov 05, 2011 3:06 am
by yb0djh
Hi ALL


This is my first Class E, i build it back in 2008 - 2009 with so many failure and burned MOSFETs.

My RF Deck is running about 500 watt carrier, 50 V with 10 Amps. I m using 4 Mosfet IRFP460C double push pull.

Modulator is PWM using 2 x IRFP 250 driven by IRF2015 (high side driver) PWM using TL494.

My Shack

Image


My RF Deck

Image


Other side of RF Deck

Image

The Waveform (one of the push pull leg)

Image

The audio engine

Image


Need your comments and feedback


Thank You and Best Regards from Indonesia (Jakarta)

de yb0djh 73s

Re: First Class E from Indonesia

PostPosted: Mon Nov 07, 2011 4:02 pm
by Gilly
Hi BR

Thanks for posting your photos and congratulations on all your constructions ..... all looks good...
Those poor IRFP460 are really working hard...
What level of modulation are you running ?
Your output cores ... do they get hot ?
Could you post a photo of the PWM circuitry....

Wayne

Re: First Class E from Indonesia

PostPosted: Tue Nov 08, 2011 8:33 am
by Diego-CX4DI
Congratulations!!!

I hope your schematic and test results soon.

best 73's
Diego
CX4DI
cx4di@adinet.com.uy

QRZ.com/cx4di

Re: First Class E from Indonesia

PostPosted: Thu Nov 10, 2011 8:08 am
by yb0djh
Gilly wrote:What level of modulation are you running ?


I still have a problem with modulator, it seems i cannot reach 100% modulation. The modulation up swing become flatten about 15 % before peak and it creates distortion. So i keep 80% of modulation. Anyone can help in this problem?

Your output cores ... do they get hot ?


I m not using bead cores as all friends here use, i m using toroid (i took from Cushcraft R7 toroid choke) there is no saturation indication, toroid is not hot. The efficiency probably reaching 90%. All MOSFETs are cold and happy after i found 500pf C Shunt before it was to large 1000 pf, so i reducing gradually while watching the waveform. I will post RF section schematic soon, just finished it with visio.

Could you post a photo of the PWM circuitry....


here is the schematic

Image

Thanks for response

73s

Re: First Class E from Indonesia

PostPosted: Fri Nov 11, 2011 9:21 pm
by Gilly
Hi BR

Is that your name ?

OK on only 80% modulation...
What is your High Voltage from the Power Supply ?
Also 50Volts at 10Amps is a lot of power and it has to manage modulation peaks as well....do you have enough capacitance in the supply ?
Noticed you have a Oscilliscope there...use it to check the supply waveform....
Running 50Volts Carrier level to achieve 100% you would need 100Volts.....minimum....
To be safe 130Volts would be nice for your system....

Also when testing your Modulator into a dummy load ..... is it OK ? is there any clipping ?

Another test would be to run the TX at reduced power level and see if all goes well !


Wayne

Re: First Class E from Indonesia

PostPosted: Sat Nov 12, 2011 6:58 am
by yb0djh
Gilly wrote:Hi BR Is that your name ?


I m so sorry, my name is Agus Hadi. Call me Agus.

Gilly wrote:What is your High Voltage from the Power Supply ?
Also 50Volts at 10Amps is a lot of power and it has to manage modulation peaks as well....do you have enough capacitance in the supply ?
Noticed you have a Oscilliscope there...use it to check the supply waveform....
Running 50Volts Carrier level to achieve 100% you would need 100Volts.....minimum....
To be safe 130Volts would be nice for your system....
Also when testing your Modulator into a dummy load ..... is it OK ? is there any clipping ?
Another test would be to run the TX at reduced power level and see if all goes well !


Thanks for your advice Gilly, i will try those tests.

Yes, when i did test with 5 ohm dummy on my modulator, there was clipping on waveform.

I just finished test tone generator, before i was using software tone generator via soundcard. i will make another test either with dummy load or reduced power of transmitter. I will report it here.

Thank you

73s Agus-yb0djh

Re: First Class E from Indonesia

PostPosted: Sat Nov 12, 2011 7:47 am
by Gilly
Hi Agus

Just one other thing....can you vary the carrier voltage / output voltage of your PWM ?
It would be good to reduce the voltage from 50Volts to appox 30/35 volts for this testing..
When all is well then play around with the power level....
Say 30Volts @ 4 Amps for the moment......
Is that possible ?


Wayne

Re: First Class E from Indonesia

PostPosted: Thu Nov 17, 2011 7:05 am
by yb0djh
Gilly wrote:Hi Agus

Just one other thing....can you vary the carrier voltage / output voltage of your PWM ?
It would be good to reduce the voltage from 50Volts to appox 30/35 volts for this testing..
When all is well then play around with the power level....
Say 30Volts @ 4 Amps for the moment......
Is that possible ?


Wayne



Yes possible. there is a trimmer to adjust the carrier level.

BR

Agus - YB0DJH

Re: First Class E from Indonesia

PostPosted: Fri Nov 18, 2011 1:27 am
by Gilly
OK thats good :D

Re: First Class E from Indonesia

PostPosted: Mon Nov 28, 2011 6:57 am
by Diego-CX4DI
Could you post a photo of the PWM modulator?

rgs,
diego
CX4DI

Re: First Class E from Indonesia

PostPosted: Tue Dec 27, 2011 9:32 am
by steve_qix
I see several MAJOR problems.

First, the IRFP460 has too low a voltage rating. You would have to cut the POWER SUPPLY VOLTAGE to 70 volts. Changing the carrier voltage won't fix it. It's the TOTAL POWER SUPPLY VOLTAGE that is the issue. You will not be able to control the modulation all the time. The total power supply voltage has to be reduced to no more than 70 volts. The current will also have to drop in proportion so the PWM filter will be properly terminated.

Second: I don't see any transzorbs. You are using analog drive without over voltage protection. You need transzorbs on both the gates and the drains.

Third: Do you have an overload shutdown? How is it implemented?

The MOSFET drain voltage rating should be at least 7 times the total power supply voltage.

Re: First Class E from Indonesia

PostPosted: Wed Dec 28, 2011 11:17 pm
by yb0djh
Hi Steve

I m very glad to see comments from guru. Thank you.

Thank you for your advise on these safety devices, transorbs on drain, gate also circuit breaker. Maybe later when i have done all my experiments on many aspects of class E i will fix it. To protect it i m not inserting modulation yet.

At this moment just busy to collecting the components, since i cannot find it in Jakarta, especially ferrite bead, C shunt, Mosfet driver, PWM Toroid. When all done i will try to replace it with components which are ready locally, so that many friends here can also enjoy the cheap RF machine.

BR 73s Agus-YB0DJH

Happy New Year 2012