Page 1 of 1

Potential hum problem in PWM Generator from class E web site

PostPosted: Thu Apr 21, 2005 5:49 pm
by steve_qix
Hi!

Thanks to Brent, W1IA, he and I found a potential problem (and have corrected it with a simple change) with the simplified, two chip PWM generator.

The problem, as evidenced by W1IA's transmitter, is a slight 120hZ hum. The hum comes about if the ripple on the unregulated 17 volt supply - the supply that supplies the PWM chip - exceeds more than about 10%.

A simple solution to this problem is to add a 22 ohm resistor in series with the 17 volt unregulated supply, and a 2200uF 25V capacitor to ground, after the 22 ohm resistor.

I use the original circuit in my own transmitter, with no problems, however the hum did show up in Brent's transmitter.

I have attached the updated schematic, and the schematic is also available at the class E web site.

Regards,

Steve
Image

PostPosted: Sat Apr 23, 2005 3:05 pm
by W1DAN
Hi Steve:

Thanks for the update here and all your previous work. I am having a really great time with my transmitter.

I feed my UCC25701 from a regulated 15v supply (7815 regulator).

The data sheet says the absolute maximum voltage here should not exceed 15v. The IC zener shunt regulates to 14v. But since you are feeding 17v into it, that maximum value has some room.

Another thing I did was to use a CD4011 inverter at the output of this chip to invert the TTL output. So when I turn off the pulse train the PWM power section turns off (and not goes full as before). As you know the negative peak clipper has to be reversed (I am not using it in mine as I have an external processor that has a clipper) as well.

I also soft start the chip by adding about 33uf capacity and a shorting switch from pin 14 to ground. When the switch is shorted, there is no output. When the switch is opened, the PWM ramps up within about 1/4 second.

Thanks again for all your efforts. It is all great fun!

73
Dan
W1DAN

PostPosted: Wed Apr 27, 2005 5:21 pm
by KM5TZ/6
W1DAN wrote:Hi Steve:

Thanks for the update here and all your previous work. I am having a really great time with my transmitter.

I feed my UCC25701 from a regulated 15v supply (7815 regulator).

The data sheet says the absolute maximum voltage here should not exceed 15v. The IC zener shunt regulates to 14v. But since you are feeding 17v into it, that maximum value has some room.



Good catch Dan,

Looks like the 120 ohm resistor should be increased to about 220 ohms for a 17.5V supply. I would have expected the shunt regulator to take care of any ripple. I'll have to check mine...

David
KM5TZ

UCC25701 PWM GENERATOR

PostPosted: Sat Jul 02, 2005 3:02 pm
by Todd WD4NGG
Hi Steve and Dan, thanks for the update and comments for eliminating a potential hum problem in the UCC25701 PWM Generator board. Looks like a really simple circuit and will be a fun summer project! 73 Todd WD4NGG